Bug report #20804

Symbology of a layer with categories based on boolean field displays nothing

Added by Jan Macura over 1 year ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:3.4.2 Regression?:No
Operating System:Windows 10 Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:28624

Description

This issue is kind of hard to describe, so I will describe what exactly I am doing and where I see a problem.

Steps to reproduce
  1. Create new GeoPackage layer. Draw few lines or polygons or whatewer.
  2. Create new column in the attribute table with a boolean datatype.
  3. Edit layer and mark some of the features as True, left some others with False.
  4. Go to Properties->Symbology. Choose Categories and the newly created column. Then classify features.
    • (So far it works just great)
      1. Click ok and check the features in the map.

What happens
In my case, I am left with the empty screen, although the classification assigned a symbology to each feature. If I elaborate and try other types of symbology (simple style, categories based on integer/string columns), it works as expected. Geometry of the layer does not matter (tested this with lines and polygons). Loading existing layer instead of creating new one makes no difference.

What should happen
The features should be displayd according to the symbology which is set in the layer properties.

I am including some testing data.

pokus_chyby.gpkg - testing gpkg with lines (96 KB) Jan Macura, 2018-12-13 07:39 PM

pokus_chyby_poly.gpkg - testing gpkg with polygons (96 KB) Jan Macura, 2018-12-13 07:39 PM

History

#1 Updated by Nyall Dawson over 1 year ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Duplicate of #20290

Also available in: Atom PDF