Bug report #20803

grass algorithms on geopackage vecto change fid tpe

Added by Ludovico Frate almost 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:GRASS
Affected QGIS version:2.18.26 Regression?:No
Operating System:windows 10 Easy fix?:No
Pull Request or Patch supplied:No Resolution:up/downstream
Crashes QGIS or corrupts data:No Copied to github as #:28623

Description

Hi,
when using a vector file stored in a GeoPackage to run any grass algorithm, in the output vector file the type of the fid column changes from INTEGER to REAL. This is quite annoiyng because if you need to import the output vecotr in the GeoPackages you must remove the fid column otherwise you will get an error message since the fid column is REAL.

Regards,
Ludovico

History

#1 Updated by Nyall Dawson almost 2 years ago

  • Resolution set to up/downstream
  • Status changed from Open to Closed

This is a grass issue, not qgis.

Also available in: Atom PDF