Bug report #20774

Vertex tool wrong behavior

Added by Nikolai Krawczak about 1 year ago. Updated 12 months ago.

Status:Closed
Priority:High
Assignee:Martin Dobias
Category:Digitising
Affected QGIS version:3.5(master) Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:28594

Description

when creating a new node with topological editing active this happens:

expected behaviour would be being able to create a new node for both adjacent polygons, which works for me most of the time.

I attached a Project file and gpkg.

vertex_edit.gif (382 KB) Nikolai Krawczak, 2018-12-11 02:39 PM

vertex_tool.qgz (4.35 KB) Nikolai Krawczak, 2018-12-11 02:46 PM

polygon.gpkg (96 KB) Nikolai Krawczak, 2018-12-11 02:46 PM

Associated revisions

Revision 3769faa8
Added by Martin Dobias 12 months ago

[vertex tool] Fix vertex addition to polygon's first segment (fixes #20774)

With topo editing mode enabled, addition of extra points to keep the topology
correct wasn't working correctly because for the first segment we were getting
two matches due to duplicated first and last vertex in the ring. The fix
ensures that only one match will be returned for the first duplicated vertex.

Revision 4423caff
Added by Martin Dobias 12 months ago

[vertex tool] Fix vertex addition to polygon's first segment (fixes #20774)

With topo editing mode enabled, addition of extra points to keep the topology
correct wasn't working correctly because for the first segment we were getting
two matches due to duplicated first and last vertex in the ring. The fix
ensures that only one match will be returned for the first duplicated vertex.

(cherry picked from commit 3769faa86b89b14dbde51adc19ff858469ced6f3)

History

#1 Updated by Giovanni Manghi about 1 year ago

  • Priority changed from Normal to High
  • Regression? changed from No to Yes

#2 Updated by Jan Lippmann about 1 year ago

i can confirm this issue

#3 Updated by Jan Lippmann about 1 year ago

actual master 48db864836 is also affected

#4 Updated by Giovanni Manghi about 1 year ago

  • Operating System deleted (Win 7 64)
  • Affected QGIS version changed from 3.4.2 to 3.5(master)
  • Subject changed from Vertex Tool odd behavior to Vertex too wrong behavior

#5 Updated by Martin Dobias 12 months ago

  • Status changed from Open to In Progress
  • Subject changed from Vertex too wrong behavior to Vertex tool wrong behavior
  • Assignee set to Martin Dobias

#6 Updated by Martin Dobias 12 months ago

  • % Done changed from 0 to 100
  • Status changed from In Progress to Closed

#7 Updated by Giovanni Manghi 12 months ago

  • Resolution set to fixed/implemented

Also available in: Atom PDF