Bug report #20758

Print Composer doesn't show symbols in legend

Added by John Payne over 1 year ago. Updated over 1 year ago.

Status:Closed
Priority:High
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:3.4.2 Regression?:Yes
Operating System:OS X 10.14.1 (Mojave) Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:28578

Description

I'm trying to implement a workaround for making a Print Composer legend for a symbol that has two characteristics: size (related to one variable) and color (related to another). The workaround consists of duplicating the layer and showing the characteristics separately.

In the attached file, you can see that the symbols for "Number of visitors" show correctly in the Legend "Item Properties" dialog, but they don't appear on the Print Composer legend itself.

I find the Print Composer extremely frustrating to use, because of its multiple bugs and inconsistencies.

Screen Shot 2018-12-08 at 4.19.51 PM.png (496 KB) John Payne, 2018-12-09 02:33 AM

History

#1 Updated by Giovanni Manghi over 1 year ago

  • Category changed from Map Legend to Map Composer/Printing
  • Status changed from Open to Feedback
  • Subject changed from Print Composer doesn't show symbols to Print Composer doesn't show symbols in legend

Does it works as expected on 2.18?

#2 Updated by John Payne over 1 year ago

Giovanni Manghi wrote:

Does it works as expected on 2.18?

Yes, it shows the symbols as expected. It seems no longer possible to collect the different size symbols inside the largest one, though, which is a nice feature; instead it shows them all spread out.

#3 Updated by Giovanni Manghi over 1 year ago

  • Status changed from Feedback to Open
  • Regression? changed from No to Yes
  • Priority changed from Normal to High

#4 Updated by Nyall Dawson over 1 year ago

  • Status changed from Open to Closed
  • Resolution set to duplicate

Duplicate of #9747 (also a symptom of #11491)

#5 Updated by Giovanni Manghi over 1 year ago

Nyall Dawson wrote:

Duplicate of #9747 (also a symptom of #11491)

The issuer says it works as expected on 2.18, so this could not be a duplicate after all. Can the issuer confirm it please?

Also available in: Atom PDF