Bug report #2073

crash when removing a layer

Added by Paolo Cavallini almost 10 years ago. Updated almost 10 years ago.

Status:Closed
Priority:Low
Assignee:Martin Dobias
Category:Map Legend
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:12133

Description

When removing any layer from the legend, qgis segfaults immediately

History

#1 Updated by Paolo Cavallini almost 10 years ago

Same thing when adding a layer to a group, etc.

#2 Updated by Borys Jurgiel almost 10 years ago

and also when removing from the overview

#3 Updated by Giovanni Manghi almost 10 years ago

Hi,

the problem was partially solved in rev.12059. It still crashes if you try to put a layer into a group.

#4 Updated by Martin Dobias almost 10 years ago

  • Status changed from Open to Closed
  • Resolution set to fixed

Adding layer to a group works again in 145a9e53 (SVN r12068).

Borys: i'm unable to replicate crash when removing layer from overview...

#5 Updated by Giovanni Manghi almost 10 years ago

Borys: i'm unable to replicate crash when removing layer from overview...

I guess was already fixed with the other patch. At least seem so.

#6 Updated by Borys Jurgiel almost 10 years ago

Yes, now is working!

Also available in: Atom PDF