Bug report #20646

i.segment (GRASS 7.4.2) only produces a Goodness Raster but no Segmented Raster

Added by Friedemann Scheibler 9 months ago. Updated 3 months ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Processing/GRASS
Affected QGIS version:3.4.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:28466

Description

I am trying to segment a single band raster dataset using the GRASS tool "i.segment" (GRASS version 7.4.2) with standard settings. With the previous GRASS version, this worked without problems using the same dataset. Now, the resulting "Segmented Raster" only has no data values. Interestingly, the "Goodness Raster" seems to be correct. I did not receive any error messages. This affects QGIS 3.4.1 and QGIS 2.18.26 in the same way.

I attached the image I was trying to segment to this ticket.

test.tif - Sentinel 2 image (78.5 KB) Friedemann Scheibler, 2018-11-27 03:58 PM

History

#1 Updated by Alexander Bruy 7 months ago

  • Status changed from Open to Feedback
  • Operating System deleted (MS Windows 10 Enterprise)

Does this module works as expected when used in GRASS GIS directly?

#2 Updated by Giovanni Manghi 5 months ago

Just tested on 3.6 and works.

#3 Updated by Friedemann Scheibler 5 months ago

You're right. It's working now with Grass 7.6.

#4 Updated by Giovanni Manghi 5 months ago

Friedemann Scheibler wrote:

You're right. It's working now with Grass 7.6.

does it on 3.4.5?

#5 Updated by Alexander Bruy 3 months ago

  • Resolution set to worksforme
  • Status changed from Feedback to Closed

Works fine both in master and latest 3.4

Also available in: Atom PDF