Bug report #20619

SLD load problem

Added by Eduardo Martín about 1 year ago. Updated 7 months ago.

Status:Feedback
Priority:High
Assignee:-
Category:Symbology
Affected QGIS version:3.4.1 Regression?:Yes
Operating System:win10 x64 Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:28439

Description

I use a SLD file to define styles over a polygon layer, but the results are different depending on the QGIS version: 2.18.25 and 3.4.1 don't work (missing layer cause of styling), 2.18.4 and 3.2.3 work.
Even, I tried to create a SLD on 2.18.25 and load over the same layer, the styling doesn't work.

I attached gif example of a success and a failed cases.

Thanks for your time and help developping this great software!
Regards :)

SLD_2_18_25.zip (4.77 MB) Eduardo Martín, 2018-11-24 05:55 PM

SLD_3.2.3.gif (4.94 MB) Eduardo Martín, 2018-11-24 05:56 PM

History

#1 Updated by Giovanni Manghi about 1 year ago

  • Regression? changed from No to Yes
  • Affected QGIS version changed from 2.18.25 to 3.4.1
  • Priority changed from Normal to High

#2 Updated by Alexander Bruy 7 months ago

  • Status changed from Open to Feedback

Please provide test data and steps to reproduce

Also available in: Atom PDF