Bug report #20583

Raster calculator freezes the GUI with big rasters

Added by Alessandro Pasotti about 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Normal
Assignee:Alessandro Pasotti
Category:Raster Calculator
Affected QGIS version:3.5(master) Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:28403

Description

Raster is a dem 40000x40000 and even with a simple expression it takes ages and the GUI completely freezes (no cancellation is possible: it is disabled in code)

This makes the tool completely unusable for large rasters.

Associated revisions

Revision d3d18050
Added by Alessandro Pasotti almost 2 years ago

Re-add the progress bar to the calculator

Fixes #20583 - Raster calculator freezes the GUI with big rasters

... even if it is frozen while reding the raster,
at least it allows to abort the process later

Revision e2a2aecc
Added by Alessandro Pasotti almost 2 years ago

Merge pull request #8550 from elpaso/bugfix-20583-19760-raster-calculator

Raster calculator crash and hang fixes. Fixes #20583 #19760

Revision 273a71a7
Added by Alessandro Pasotti almost 2 years ago

Re-add the progress bar to the calculator

Fixes #20583 - Raster calculator freezes the GUI with big rasters

... even if it is frozen while reding the raster,
at least it allows to abort the process later

History

#1 Updated by Giovanni Manghi about 2 years ago

  • Status changed from Open to Feedback

Hi Alessandro, likely duplicate of #13336 ?

#2 Updated by Alessandro Pasotti almost 2 years ago

  • Assignee set to Alessandro Pasotti

Yeah, related but not the same bug.

#3 Updated by Anonymous almost 2 years ago

  • % Done changed from 0 to 100
  • Status changed from Feedback to Closed

#4 Updated by Giovanni Manghi almost 2 years ago

Thanks Alessandro for tackling this, it was MUCH needed.

#5 Updated by Alessandro Pasotti almost 2 years ago

  • Status changed from Closed to Reopened

I actually fixed the "big" issue (the crash #13336) but I couldn't do much for the first part of GUI freeze: this is happening because the rasters are read as a whole and that operation is not interruptable.

But, once the raster are read and the computation starts, the progress bar now appears and the operation can be interrupted.

So, since this is a partial fix, I'm going to leave this open.

#7 Updated by Alessandro Pasotti almost 2 years ago

  • Status changed from Reopened to Closed

Also available in: Atom PDF