Bug report #2049

Choosing Move Item Content in the print composer override Lock Layers

Added by Luca Casagrande almost 10 years ago. Updated almost 10 years ago.

Status:Closed
Priority:Low
Assignee:Marco Hugentobler
Category:-
Affected QGIS version: Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied: Resolution:wontfix
Crashes QGIS or corrupts data: Copied to github as #:12109

Description

Hello folks:

  • Add the vector data attached to the ticket
  • Choose Unique Value Style
  • Create a new printer composer instance, add the map and set Lock Layers On
  • Back to Qgis and change the style of the layer to anything and add it to the print composer
  • Qgis is fine and the two maps have got different style
  • From the composer toolbar choose "Move Item Content" and click on the first map (the one with the Lock On)
  • After moving the map the style change as the Lock is Off.

sample.zip - Sample data (8.05 KB) Luca Casagrande, 2009-11-05 04:49 AM

History

#1 Updated by Marco Hugentobler almost 10 years ago

  • Resolution set to wontfix
  • Status changed from Open to Closed

This is intended. 'Lock layers' means only to lock the layers displayed in a composer map, not their appearance.

Common use-case is this: you have 10 layers, but like to only display 2 of them in an overview map. So you set the 2 layers visible, add a composer map (as overview), select 'lock layers'. Then you go back to main map, set all 10 visible and add a second composer map in composer. Like that, you can have 2 composer maps displaying different layer sets (not layer styles).

Also available in: Atom PDF