Bug report #20455

Widget Value Relation

Added by Lene Fischer almost 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Normal
Assignee:Alessandro Pasotti
Category:Forms
Affected QGIS version:3.4.1 Regression?:No
Operating System:Windows 7 Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:28275

Description

I have made a project with a point layer and two lookup tables: Group and Subgroup in the Subgroup tabel is listed 'group', 'subgroup' and 'label'

In the Layer properties >Attriute Form > Widget type >Value Relation I have made settings to lookup in the 'Group' lookup and the sub group.
That works fine. The first group and subgroup is shown. If I choose a new Group the new subgroup item are shown.
But the 'label' is not set correct. All the features in the table are shown.

If I choose a new group and subgroup the label are set - but only if the subgroup consist of more than one item.

I have made a video https://www.screencast.com/t/mKEjlmfBIxFK

froedal_delvis.qgs (100 KB) Lene Fischer, 2018-11-11 09:00 PM

hilleroed_lille_omraade.gpkg (508 KB) Lene Fischer, 2018-11-11 09:00 PM

Associated revisions

Revision d479b4dc
Added by Alessandro Pasotti almost 2 years ago

Emit valueChanged when a widget value changes as a consequence of another widget changed

Fix #20455

History

#1 Updated by Alessandro Pasotti almost 2 years ago

I can't see the screencast (no flash player here since a long time).

#2 Updated by Alessandro Pasotti almost 2 years ago

Also, if you could attach a sample project and data, that would be perfect.

#5 Updated by Alessandro Pasotti almost 2 years ago

  • Status changed from Open to Feedback

Hi Lene,

I may have a fix for this issue, would you be able to test a windows build? (I can quickly package and send you a test build but without python support).

#6 Updated by Alessandro Pasotti almost 2 years ago

  • Category changed from Relations to Forms
  • Pull Request or Patch supplied changed from No to Yes
  • Status changed from Feedback to In Progress

#7 Updated by Alessandro Pasotti almost 2 years ago

Here is the windows test build, no need to install, just unzip somewhere and run qgis.exe, remove the folder to uninstall.

http://www.itopen.it/bulk/qgis-mxe-release-2018-11-12-15-03-01.zip

What to test:
- the original project attached to this ticket
- how does it work with new and existing features

#8 Updated by Lene Fischer almost 2 years ago

Thanks!!!! Now it works :-)

#9 Updated by Anonymous almost 2 years ago

  • % Done changed from 0 to 100
  • Status changed from In Progress to Closed

Also available in: Atom PDF