Bug report #20378

QGIS 3.4 cannot install on Mac

Added by Oskar Karlin almost 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Normal
Assignee:William Kyngesburye
Category:mac_os_specific
Affected QGIS version:3.4.0 Regression?:No
Operating System:macOS Easy fix?:Yes
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:28198

Description

A colleague of mine tried to install the latest version of QGIS on mac downloaded from QGIS.org. It's the QGIS-macOS-3.4.0-3.dmg package. Compared to earlier packages, GDAL is not included, and the installer complains:

"The GDAL 2.3 framework is required."

And then stops. Normally in these packages GDAL is installed first and then QGIS but in this package there is no GDAL.

Are you supposed to download GDAL on your own? Seems like something has changed.

Screen Shot 2018-11-06 at 10.22.27.png (197 KB) Oskar Karlin, 2018-11-06 10:25 AM

History

#1 Updated by Denis Rouzaud almost 2 years ago

  • Assignee changed from Denis Rouzaud to William Kyngesburye

#2 Updated by William Kyngesburye almost 2 years ago

  • Resolution set to fixed/implemented
  • Easy fix? changed from No to Yes
  • Status changed from Open to Closed

Oops, I was simplifying the installer and forgot to remove the test for GDAL. New installer uploaded (same -3 version) to fix.

Also available in: Atom PDF