Bug report #20349

Processing script editor mangles code

Added by Anita Graser 12 months ago. Updated 12 months ago.

Status:Closed
Priority:High
Assignee:Nyall Dawson
Category:Processing/GUI
Affected QGIS version:3.5(master) Regression?:Yes
Operating System:Windows 10, Mac Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:28170

Description

As reported on https://gis.stackexchange.com/questions/300906/qgis-3-2-processing-script-editor-display-spaces-shown-as-tabs:
The Processing script editor behaves weirdly (at least on Windows and Mac). It shows wide spacing where there should be only single spaces or no space at all.
Additionally, more spaces are "magically" introduced if parts of the code are selected with the mouse.
This makes the editor unusable.

Associated revisions

Revision ea9d5bb3
Added by Nyall Dawson 12 months ago

Fix mangled fonts in script editors

Don't override default font letter spacing or stretch -- it's not
safe to do because the results are very dependent on the individual
font's appearance and rendering hints.

Fixes #20349

Revision 4cd82a28
Added by Nyall Dawson 12 months ago

Fix mangled fonts in script editors

Don't override default font letter spacing or stretch -- it's not
safe to do because the results are very dependent on the individual
font's appearance and rendering hints.

Fixes #20349

(cherry picked from commit ea9d5bb363597c8305962c4adc0b0eaaa43cbfb4)

History

#1 Updated by Anita Graser 12 months ago

  • Operating System set to Windows 10, Mac
  • Description updated (diff)

#2 Updated by Nyall Dawson 12 months ago

  • Assignee set to Nyall Dawson
  • Status changed from Open to In Progress

#3 Updated by Nyall Dawson 12 months ago

  • % Done changed from 0 to 100
  • Status changed from In Progress to Closed

Also available in: Atom PDF