Bug report #20338

Can not scroll through attribute list in dialog window when linking existing child features

Added by Andrew Fleming almost 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Normal
Assignee:Alessandro Pasotti
Category:Forms
Affected QGIS version:3.4.0 Regression?:No
Operating System:Windows 7 Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:28159

Description

Hello,

I have created a Relation between two tables in my Oracle database and am having trouble linking the parent and child features together. When I attempt to link the child to the parent using the icon in Attribute form (See "No Scroll Bar 1.jpg"), I have no way of scrolling down to the bottom of the Dialog window to confirm the link (the child table has 42 columns and I don't want to remove any of them) (See "No Scroll Bar 2.jpg").

Also, on a side note, resizing the dialog window doesn't appear to work properly either, click-and-drag on the top of the window shifts the entire panel and doesn't actually resize.

I'm hoping someone can help me.

Thanks,
Andrew

No Scroll Bar 1.jpg (97.6 KB) Andrew Fleming, 2018-11-02 08:02 PM

No Scroll Bar 2.jpg (308 KB) Andrew Fleming, 2018-11-02 08:12 PM


Related issues

Related to QGIS Application - Bug report #20701: No scroll in attribute form Open 2018-12-03

Associated revisions

Revision c962573c
Added by Alessandro Pasotti almost 2 years ago

Make sure QgsFeatureSelectionDlg does not outgrow the window

Fixes #20338 - Can not scroll through attribute list in dialog window when linking existing child features

History

#1 Updated by Giovanni Manghi almost 2 years ago

  • Status changed from Open to Feedback

Did it worked as expected on 2.18?

#2 Updated by Andrew Fleming almost 2 years ago

Giovanni Manghi wrote:

Did it worked as expected on 2.18?


No, this behaves exactly the same in 2.18.

#3 Updated by Alessandro Pasotti almost 2 years ago

I think that's a problem with the form window height, we should set a maximum.

#4 Updated by Alessandro Pasotti almost 2 years ago

  • Assignee set to Alessandro Pasotti

#5 Updated by Giovanni Manghi almost 2 years ago

  • Status changed from Feedback to Open

#6 Updated by Alessandro Pasotti almost 2 years ago

  • Pull Request or Patch supplied changed from No to Yes
  • Status changed from Open to In Progress

#7 Updated by Anonymous almost 2 years ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100

#8 Updated by Alessandro Pasotti almost 2 years ago

@Andrew, the patch has been merged, can you please test it?

#9 Updated by Andrew Fleming almost 2 years ago

Thanks Alessandro,

Unfortunately the issue remains, I can not scroll down to the bottom of the 'Dialog' window or resize it.

I just updated my QGIS to V.3.4.1 perhaps this could be the reason?

#10 Updated by Alessandro Pasotti almost 2 years ago

It's not in 3.4.1, you have to test the nightly builds.

#11 Updated by Jürgen Fischer almost 2 years ago

Also available in: Atom PDF