Bug report #20265

3.4 explore button for adding missing layers is disabled

Added by Pavel Popoca Cruz almost 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Normal
Assignee:Nyall Dawson
Category:Data Source Manager
Affected QGIS version:3.4.0 Regression?:No
Operating System:Windows 8.1 Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:28086

Description

When opening a saved project, and the Manage missing layers shows up, the 'explore' button isn't working properly: it appears locked and disabled, so the only way to add missing layers is manually editing the address for data source.

bug.PNG - screenshot (159 KB) Pavel Popoca Cruz, 2018-10-29 11:23 PM

Associated revisions

Revision 0d7f5986
Added by Nyall Dawson almost 2 years ago

Fix broken handle bad layers dialog

Partially revert af0bae67f and ea2cc365

Fixes #20265

Revision 370e87e7
Added by Nyall Dawson almost 2 years ago

Fix broken handle bad layers dialog

Partially revert af0bae67f and ea2cc365

Fixes #20265

(cherry picked from commit 0d7f59865b072c29f853513eb183c674585981ba)

History

#1 Updated by Nyall Dawson almost 2 years ago

  • Assignee set to Nyall Dawson
  • Status changed from Open to In Progress

#2 Updated by Pavel Popoca Cruz almost 2 years ago

It also happens on Ubuntu 18.04

#3 Updated by Nyall Dawson almost 2 years ago

  • % Done changed from 0 to 100
  • Status changed from In Progress to Closed

Also available in: Atom PDF