Bug report #20242

missing last segments of DXF exported polylines

Added by Kepes Ádám almost 2 years ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:Jürgen Fischer
Category:DXF export
Affected QGIS version:3.2.3 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:28063

Description

while 3d exporting LineString25D polyline dxf or shp the last line segments... simply disappears. I think users would need that too :)
i have done it with contour lines, i don't know if it still happens while end and last point elevation is different.

failure.jpg (5.21 KB) Kepes Ádám, 2018-10-28 02:05 AM

fault.jpg (163 KB) Kepes Ádám, 2018-10-28 10:37 PM

3Dpolyline_problem.zip (520 KB) Kepes Ádám, 2018-10-29 12:26 AM

Associated revisions

Revision 56ec4732
Added by Jürgen Fischer over 1 year ago

dxf export: fix output of closed 3d polylines (fixes #20242)

Revision db823175
Added by Jürgen Fischer over 1 year ago

dxf export: fix output of closed 3d polylines (fixes #20242)

(cherry picked from commit 56ec47328b9e24951b51c00144221c95f88c6c83)

History

#1 Updated by Giovanni Manghi almost 2 years ago

  • Status changed from Open to Feedback
  • Easy fix? changed from Yes to No

please try 3.4

#2 Updated by Kepes Ádám almost 2 years ago

Giovanni Manghi wrote:

please try 3.4

see the picture attached...

2.18 had problems with dxf height exports, but since then it just got worse

#3 Updated by Nyall Dawson almost 2 years ago

Can you share a self contained project & simple data file we can use as a test case here?

#4 Updated by Kepes Ádám almost 2 years ago

Nyall Dawson wrote:

Can you share a self contained project & simple data file we can use as a test case here?

Of course Nyall! Just call if i can help in anything!

#5 Updated by Giovanni Manghi almost 2 years ago

  • Status changed from Feedback to Open

#6 Updated by Jürgen Fischer over 1 year ago

  • Assignee set to Jürgen Fischer

#7 Updated by Jürgen Fischer over 1 year ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

Also available in: Atom PDF