Bug report #20213

Network setting doesn't follow proxy settings for web access in Windows 10

Added by Christoph Candido over 1 year ago. Updated about 1 year ago.

Status:Open
Priority:High
Assignee:-
Category:Network
Affected QGIS version:3.6.0 Regression?:Yes
Operating System:Windows 10 Enterprise Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:28034

Description

QGIS 3.3.0-Master doesn't follow it's own proxy settings for web access in Windows 10 Enterprise.
It only follows the general proxy settings in Windows.

We cannot disable the proxy in QGIS, if the proxy is allready configured in Windows (Local Area Network Settings -> Proxy Server).
(The Windows environment variables http_proxy,https_proxy,no_proxy don't help and are not defined)

As a result of the problem, we cannot open local WMS services inside our network.
The WMS request allways runs over our central proxy with NTLM authentication, which QGIS refuses to handle.

Capture.JPG - proxy settings (22 KB) Christoph Candido, 2019-03-16 07:14 PM

Associated revisions

Revision cf1cf0fe
Added by Nyall Dawson over 1 year ago

Fix empty strings in proxy exclude list results in proxy being skipped for ALL hosts

Fixes #20213

Revision 34625110
Added by Nyall Dawson over 1 year ago

Fix empty strings in proxy exclude list results in proxy being skipped for ALL hosts

Fixes #20213

(cherry picked from commit cf1cf0fe455a42edf6db4ab9fa07c1ad641b16cb)

History

#1 Updated by Saber Razmjooei over 1 year ago

  • Subject changed from QGIS 3.3.0 doesn't follow proxy settings for web access in Windows 10 to Network setting doesn't follow proxy settings for web access in Windows 10

#2 Updated by Giovanni Manghi over 1 year ago

  • Category changed from Windows Package to Network
  • Assignee deleted (Jürgen Fischer)
  • Priority changed from High to Normal

#3 Updated by Uwe Schmitz over 1 year ago

This Bug is a real show stopper for me.
It seems that QGIS doesn't take notice
of the URL exception list made in options
network dialog.
In QGIS2.18 it works like a charm. So I think
this is a regression, should have high priority
and IMHO is easy to fix (e.g. take the code from 2.18).
At last I may mention that I work with Win7.
So the OS for this bug ist not Win10 solely.

#4 Updated by Giovanni Manghi over 1 year ago

  • Regression? changed from No to Yes
  • Priority changed from Normal to High
  • Affected QGIS version changed from 3.3(master) to 3.4.1

#5 Updated by Nyall Dawson over 1 year ago

  • Status changed from Open to In Progress
  • Assignee set to Nyall Dawson

#6 Updated by Nyall Dawson over 1 year ago

  • Status changed from In Progress to Closed
  • % Done changed from 0 to 100

#7 Updated by Uwe Schmitz about 1 year ago

In nersion 3.6.0-1 the bug is still present.
It's not possible to access URLs from
exception list if a HttpProxy is set.
It seems that QGIS continues to ignore the
exception list.

#8 Updated by Christoph Candido about 1 year ago

  • Status changed from Closed to Reopened

Unfortunately, the bug is still present.
QGIS continues to ignore it's own Proxy Settings. It always takes the Proxy Settings from Windows.

#9 Updated by Giovanni Manghi about 1 year ago

  • Affected QGIS version changed from 3.4.1 to 3.6.0
  • Status changed from Reopened to Open
  • Assignee deleted (Nyall Dawson)

#10 Updated by Christoph Candido about 1 year ago

The Proxy Setting mechanism is fine, only the exclusion of our internal servers is ignored.
May be the source of the problem is the change from QString to QStringList for the value of proxyExcludedUrls (see attachment).

Also available in: Atom PDF