Bug report #20211

Crash on exiting QGIS master

Added by Andreas Neumann about 2 years ago. Updated about 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Unknown
Affected QGIS version:3.3(master) Regression?:No
Operating System:Linux Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:Yes Copied to github as #:28032

Description

I am experiencing crashes when closing QGIS with the most recent master:

When I open QGIS (no plugins enabled, completely empty and new profile), and I do nothing (not even a simple project opened).

I close QGIS and it crashes on closing.

Am I the only one experiencing such crashes on closing?

System: Linux Ubuntu 18.04.1 LTS

QGIS: most recent master, self-compiled.

Maybe an issue only on my machine?

Stack trace:

QGIS died on signal 11[New LWP 6735]
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
0x00007f1d236456c2 in __GI___waitpid (pid=6744, stat_loc=0x7fff41e120ac, options=0) at ../sysdeps/unix/sysv/linux/waitpid.c:30
30      ../sysdeps/unix/sysv/linux/waitpid.c: Datei oder Verzeichnis nicht gefunden.
[Current thread is 1 (Thread 0x7f1d2741e980 (LWP 6734))]
#0  0x00007f1d236456c2 in __GI___waitpid (pid=6744, stat_loc=0x7fff41e120ac, options=0) at ../sysdeps/unix/sysv/linux/waitpid.c:30
        resultvar = 18446744073709551104
        sc_cancel_oldtype = 0
#1  0x000055cadcbcfffe in qgisCrash(int) ()
#2  0x00007f1d2359ff20 in <signal handler called> () at /lib/x86_64-linux-gnu/libc.so.6
#3  0x00007f1d25b2e718 in QgsCoordinateReferenceSystem::~QgsCoordinateReferenceSystem() () at /usr/local/lib/libqgis_core.so.3.3.0
#4  0x00007f1d25b8ba1d in QHash<QString, QgsEllipsoidUtils::EllipsoidParameters>::deleteNode2(QHashData::Node*) () at /usr/local/lib/libqgis_core.so.3.3.0
#5  0x00007f1d23ff46c9 in QHashData::free_helper(void (*)(QHashData::Node*)) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f1d235a4615 in __cxa_finalize (d=0x7f1d26692c00) at cxa_finalize.c:83
        check = 4159
        cxafn = <optimized out>
        cxaarg = <optimized out>
        f = 0x55cadef39e10
        funcs = 0x55cadef39c60
#7  0x00007f1d2582e453 in __do_global_dtors_aux () at /usr/local/lib/libqgis_core.so.3.3.0
#8  0x00007fff41e13550 in  ()
#9  0x00007f1d272a8b73 in _dl_fini () at dl-fini.c:138
        array = 0x7f1d274c0068 <_rtld_global+8>
        i = <optimized out>
        l = 0x7f1d2746d510
        maps = 0x7fff41e12950
        i = <optimized out>
        l = <optimized out>
        nmaps = <optimized out>
        nloaded = <optimized out>
        ns = 0
        do_audit = <optimized out>
        __PRETTY_FUNCTION__ = "_dl_fini" 
gdb returned 0
Abgebrochen (Speicherabzug geschrieben)

valgrind_qgis.txt Magnifier - Valgrind output (2.54 MB) Andreas Neumann, 2018-10-24 08:51 PM

valgrind_qgis.txt Magnifier - Full valgrind log (4.56 MB) Andreas Neumann, 2018-10-24 09:01 PM

History

#1 Updated by Andreas Neumann about 2 years ago

Seems like valgrind stopped outputting information.

Should I run it again with --error-limit=no ?

Perhaps the necessary information is now cut off ...

#2 Updated by Andreas Neumann about 2 years ago

Now attaching the full valgrind log.

#3 Updated by Tobias Wendorff about 2 years ago

Andreas Neumann wrote:

Am I the only one experiencing such crashes on closing?

I'm experiencing such crashes on exist for several months now. I've never inspected it further, but I think a plugin is the reason. It didn't crash on a fresh installation, but after adding all my standard plugins, it crashed again. Windows 7/10

#4 Updated by Even Rouault about 2 years ago

The log is useful, but can't really explain why such errors would occur. Hum, when I had similar errors in the past, it was due to having several versions of native providers / plugins from the current version and past version. But normally we have modified things so that this should no longer occur. But just in case can you try removing completely /usr/local/lib/qgis and removing all /usr/local/lib/libqgis* files, and "sudo make install" again .

#5 Updated by Andreas Neumann about 2 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

This did it. You were right. Old versions of qgis libraries around 2.99 and such.

After removing everything and reinstalling, the crash is gone.

Thanks a lot!

Also available in: Atom PDF