Bug report #20200

wrong sequence detection under postgres

Added by Jan Lippmann over 1 year ago. Updated over 1 year ago.

Status:Closed
Priority:High
Assignee:Alessandro Pasotti
Category:Data Provider/PostGIS
Affected QGIS version:3.3(master) Regression?:No
Operating System:Win 7 64bit Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:28021

Description

there is an issue with sequence detection under postgres when the layer is not in the public schema.
the problem is in the attribute form. ok button is not active because the "." point between the schema name and the sequence name is missing.

qgis_sequence_detection.gif (445 KB) Jan Lippmann, 2018-10-23 10:30 PM

Associated revisions

Revision 797911e1
Added by Alessandro Pasotti over 1 year ago

Check if we have a numeric value before stripping the group separator

Fix #20200 - wrong sequence detection under postgres

This is to avoid stripping out the dot from nextval
when schema is not public and locale has a dot
decimal separator.

History

#1 Updated by Alessandro Pasotti over 1 year ago

  • Assignee set to Alessandro Pasotti

#2 Updated by Alessandro Pasotti over 1 year ago

  • Pull Request or Patch supplied changed from No to Yes
  • Status changed from Open to In Progress

#3 Updated by Anonymous over 1 year ago

  • % Done changed from 0 to 100
  • Status changed from In Progress to Closed

Also available in: Atom PDF