Bug report #20195

Theme does not work well with new Mac Mojave dark theme

Added by Denis Rouzaud about 2 years ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:Denis Rouzaud
Category:mac_os_specific
Affected QGIS version:3.3(master) Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:up/downstream
Crashes QGIS or corrupts data:No Copied to github as #:28016

Description

see

Screen Shot 2019-01-14 at 6.23.12 PM.png (316 KB) Seth Fitzsimmons, 2019-01-15 03:24 AM

Screen Shot 2019-01-14 at 6.23.43 PM.png (431 KB) Seth Fitzsimmons, 2019-01-15 03:24 AM

Screen Shot 2019-01-14 at 6.27.29 PM.png (513 KB) Seth Fitzsimmons, 2019-01-15 03:28 AM

Screen Shot 2019-01-14 at 6.30.09 PM.png (36.4 KB) Seth Fitzsimmons, 2019-01-15 03:30 AM

History

#1 Updated by Denis Rouzaud about 2 years ago

#2 Updated by Nyall Dawson about 2 years ago

Isn't this fundamentally a qt issue?

#3 Updated by Denis Rouzaud about 2 years ago

yes, most likely this one
https://bugreports.qt.io/browse/QTBUG-68891

apparently fixed in upcoming 5.12 (planned on 29.11.2018 https://wiki.qt.io/Qt_5.12_Release)

#5 Updated by Nyall Dawson almost 2 years ago

This is fixed, right?

#6 Updated by Giovanni Manghi almost 2 years ago

  • Status changed from Open to Feedback

#7 Updated by Seth Fitzsimmons almost 2 years ago

This has improved substantially in the nightlies since 3.4.3, although there are still some places that are difficult to use. I've attached a couple screenshots of the Query Builder.

When focused, it's nearly impossible to see text when entering filter expressions (when unfocused, it's actually more readable)

#8 Updated by Seth Fitzsimmons almost 2 years ago

The Attribute Table form view also suffers from some contrast issues.

In general, black text on UI elements is difficult to read.

#9 Updated by Seth Fitzsimmons almost 2 years ago

(My screenshots are from Lutra's 20190108 build, so it looks like https://github.com/qgis/QGIS/commit/aafd84812e1a0a11736d713deae35d329aab3716, etc. may have addressed these.)

#10 Updated by Mathieu Pellerin - nIRV almost 2 years ago

I think we can close this issue, the original issue reported here was most likely due to a non-fusion style (macintosh here) used against a non-default theme (night mapping). Since January 10 - https://github.com/qgis/QGIS/commit/c7abba03fbea84ecf71fd41f0c9bfe27cf65f60c - we enforce the fusion style on non-default themes.

As for possible additional refinements to night mapping, might be worth opening individual tickets to address specific issues.


EDIT: ignore the above, it's clear not about Night Mapping :)

#11 Updated by Giovanni Manghi over 1 year ago

  • Status changed from Feedback to Open
  • Priority changed from High to Normal

#12 Updated by Denis Rouzaud over 1 year ago

  • Resolution set to up/downstream
  • Status changed from Open to Closed

Qt now correctly supports Mac OS dark theme.
There are still some glitches, mainly related to QGIS customizations, but we need specific issues for these.

Also available in: Atom PDF