Bug report #20192

qgis 3.2 crashing when applying a changed rule based style on a geopackage stored on a network

Added by damien stephens about 1 year ago. Updated 11 months ago.

Status:Closed
Priority:High
Assignee:-
Category:Symbology
Affected QGIS version:3.2.3 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:no timely feedback
Crashes QGIS or corrupts data:Yes Copied to github as #:28013

Description

Adding a new rule based style to an existing style file on geopackage layer. QGIS crashes when Applied.

crash rept.txt Magnifier (1021 Bytes) damien stephens, 2018-10-23 05:26 AM

History

#1 Updated by Giovanni Manghi about 1 year ago

  • Status changed from Open to Feedback
  • Category changed from Forms to Symbology

It happens only if the datasource is o a network? Is the style saved in the db or a separate file? Can you share sample data and styles?

#2 Updated by Giovanni Manghi about 1 year ago

Please try on QGIS 3.4.1, if the issue is still valid change the affected version, thanks.

#3 Updated by Nyall Dawson 11 months ago

  • Resolution set to no timely feedback
  • Status changed from Feedback to Closed

Also available in: Atom PDF