Bug report #20186

restricting layers to be added to legend to those turned on in the selected map theme

Added by Rob Willson almost 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Normal
Assignee:Nyall Dawson
Category:Map Legend
Affected QGIS version:3.3(master) Regression?:No
Operating System:Windows 10 Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:28007

Description

in QGIS 2.18 when you had selected for your layout to "follow visibility preset" and then went to "Add layer to legend" your list of layers would be restricted to the subset of layers that were turned on for the preset (now called map theme).

This does not happen in Q3.2 or the latest Q developmental version where instead all of the layers in the project are listed.

I love the new search dialogue built into the developmental version so that you can quickly search for your layer to add to the legend; however, it is still much quicker to add the relevant layers to your legend by restricting the layers shown in the selection dialogue to those turned on in the map theme selected to be followed (i.e., checkbox for follow map theme selected).

Not sure if this would be classified as a regression or if the feature was removed intentionally.

Associated revisions

Revision 8cf64c8a
Added by Nyall Dawson almost 2 years ago

[layouts] Add option to filter "add layer to legend" dialog to
layers visible within the (linked) map only

Fixes #20186

History

#1 Updated by Giovanni Manghi almost 2 years ago

  • Regression? changed from Yes to No
  • Status changed from Open to Feedback

Can you ask in the developers mailing list if this change was introduced by design? Thanks!

#2 Updated by Rob Willson almost 2 years ago

can do

#3 Updated by Nyall Dawson almost 2 years ago

  • Status changed from Feedback to In Progress
  • Assignee set to Nyall Dawson

#4 Updated by Nyall Dawson almost 2 years ago

  • % Done changed from 0 to 100
  • Status changed from In Progress to Closed

Also available in: Atom PDF