Bug report #20164

Layouts: Scale-based Rendering error

Added by Jack Charde over 1 year ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:Alessandro Pasotti
Category:Map Composer/Printing
Affected QGIS version:3.2.3 Regression?:No
Operating System:Windows 10 Pro Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:27985

Description

Hey everyone,

Forgive me if this post is incorrectly issued, or if it is lacking information. This is my first time requesting info, and I am new to QGIS.

I am currently following the training manual and am in Chapter 5 (Creating a Map). When in the Layout Manager to compose a view-able map, the labels for the 'places' layer don't render when I zoom out to set map to the size I want it. When they do show, it's when the map is too zoomed in and you cannot see it's full extent. This is because of the scale-based rendering setting I've chosen in the main program's labels rules for the 'places' layer.

When I go back to my map to re-adjust everything, the 'places' labels won't show up when zoom out past 1:50,000, even if I set it to 1:100,000, or turn off scale-based rendering.

Does anyone know why this might be happening?

basic_map.qgz - my map, with setting current to my issue (14.1 KB) Jack Charde, 2018-10-19 01:31 AM

qgis-scale-dep-vis.png (290 KB) Alessandro Pasotti, 2018-10-23 04:23 PM

History

#1 Updated by Saber Razmjooei over 1 year ago

  • Subject changed from Bonn 3.2.3 Scale-based Rendering error to Scale-based Rendering error

#2 Updated by Giovanni Manghi over 1 year ago

  • Easy fix? changed from Yes to No

#3 Updated by Alessandro Pasotti over 1 year ago

I don't see any issue. Please check the attached image and uncheck scale dependant visibility.

#4 Updated by Alessandro Pasotti over 1 year ago

  • Subject changed from Scale-based Rendering error to Layouts: Scale-based Rendering error

#5 Updated by Alessandro Pasotti over 1 year ago

  • Status changed from Feedback to Closed
  • Resolution set to worksforme

Also available in: Atom PDF