Bug report #20142

Numeric calculation in "Merge selected features" dialog does not work

Added by Harrissou Santanna over 1 year ago. Updated over 1 year ago.

Status:Closed
Priority:High
Assignee:-
Category:Editing
Affected QGIS version:3.3(master) Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:Yes Copied to github as #:27963

Description

Select two features and click on "merge selected features" button
In the new dialog, for a numeric field try to use statistics functions like sum, count or whatever. The field in the "Merge" row becomes empty. If you try some statistics on a literal field you get the result in the field.
It's not simply a display issue given that if you do the merge, you get 0 in the numeric field.
I check "data corruption" as this is a tool that applies in-place modification and gives a wrong value you can not easily check later on/or rebuild.

History

#1 Updated by Giovanni Manghi over 1 year ago

  • Status changed from Open to Feedback

Please try on QGIS 3.4.1, if the issue is still valid change the affected version, thanks.

#2 Updated by Nyall Dawson over 1 year ago

This works fine here. You'll need to post more detailed steps to reproduce.

#3 Updated by Harrissou Santanna over 1 year ago

  • Resolution set to worksforme
  • Status changed from Feedback to Closed

can't reproduce anymore.

Also available in: Atom PDF