Bug report #20138

"Show selected features" attribute table behavior doesn't work

Added by Matthew Jurewicz almost 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Attribute table
Affected QGIS version:3.2.3 Regression?:No
Operating System:Windows 10 Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:27959

Description

Settings > Options > "Data Sources" > "Attribute table behavior" > "Show selected features" does not affect map layer attribute tables (they always show all features). This is a problem when a layer has lots of features since the attribute table loads very slowly.

Capture.PNG (8.59 KB) Matthew Jurewicz, 2018-10-18 06:45 PM

History

#1 Updated by Giovanni Manghi almost 2 years ago

  • Status changed from Open to Feedback

works as expected here on qgis/master on linux.

#2 Updated by Alessandro Pasotti almost 2 years ago

I can confirm: on master it works just fine, can you please test the latest builds?

#3 Updated by Jeffrey Bostoen almost 2 years ago

I also noticed this before earlier on, then I was recommended to use Shift + F6, which worked like expected.

#4 Updated by Matthew Jurewicz almost 2 years ago

Shift + F6 is a good work-around. The issue doesn't seem to be fixed in the latest nightly dev build. Please read description since I think we're talking about two separate things.

#5 Updated by Giovanni Manghi almost 2 years ago

Matthew Jurewicz wrote:

The issue doesn't seem to be fixed in the latest nightly dev build

it works fine here, maybe is data related? what datasource are you using?

#6 Updated by Matthew Jurewicz almost 2 years ago

Giovanni Manghi wrote:

Matthew Jurewicz wrote:

The issue doesn't seem to be fixed in the latest nightly dev build

it works fine here, maybe is data related? what datasource are you using?

I'm using a PostGIS layer. I've attached a screenshot of my setting.

#7 Updated by Giovanni Manghi almost 2 years ago

Matthew Jurewicz wrote:

Giovanni Manghi wrote:

Matthew Jurewicz wrote:

The issue doesn't seem to be fixed in the latest nightly dev build

it works fine here, maybe is data related? what datasource are you using?

I'm using a PostGIS layer. I've attached a screenshot of my setting.

same settings here, same datasource.

#8 Updated by Matthew Jurewicz almost 2 years ago

Giovanni Manghi wrote:

Matthew Jurewicz wrote:

Giovanni Manghi wrote:

Matthew Jurewicz wrote:

The issue doesn't seem to be fixed in the latest nightly dev build

it works fine here, maybe is data related? what datasource are you using?

I'm using a PostGIS layer. I've attached a screenshot of my setting.

same settings here, same datasource.

I guess it should be cancelled, assuming I'm mistaken. Shift + F6 works fine for me.

#9 Updated by Giovanni Manghi almost 2 years ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

Also available in: Atom PDF