Bug report #20103

Data Type Change in Clip Raster by Mask Layer

Added by Martin Lacayo over 1 year ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:GDAL Tools
Affected QGIS version:3.2.3 Regression?:No
Operating System: Easy fix?:Yes
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:27925

Description

In the Clip Raster by Mask Layer tool the default GDAL console call includes the -ot parameter with a default value of Float32. I believe this is unnecessary since in the absence of the parameter the input data type will be preserved. This could also be problematic when, like in my case, clipping a Byte raster without editing advanced parameters yields a Float32 raster. This will then break other tools like r.stats when trying to do pixel counts.

History

#1 Updated by Nyall Dawson over 1 year ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

Already fixed in 3.4

Also available in: Atom PDF