Bug report #20101

[Processing] "Buffer" is not listed as an edit in place algorithm for polygon layer

Added by Harrissou Santanna almost 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Normal
Assignee:Alessandro Pasotti
Category:Processing/Core
Affected QGIS version:3.3(master) Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:27923

Description

"Buffer" is not listed as an edit in place algorithm for polygon layer while "multi-ring" alg is.

Associated revisions

Revision 51c3c2a6
Added by Alessandro Pasotti almost 2 years ago

Enable in-place buffer on polygons

Fixes #20101 - "Buffer" is not listed as an edit in place algorithm for polygon layer

History

#1 Updated by Alessandro Pasotti almost 2 years ago

  • Tracker changed from Bug report to Feature request

This is not a bug but a feature request: native:buffer algorithm do not inherit from QgsProcessingFeatureBasedAlgorithm hence it is not suitable for in-place, it needs refactoring.

#2 Updated by Alessandro Pasotti almost 2 years ago

  • Assignee set to Alessandro Pasotti

Let's see if we can sneak this into 3.4 ...

#3 Updated by Alessandro Pasotti almost 2 years ago

  • Status changed from Open to Feedback

Wait, the dissolve option is a showstopper: there is no way to maintain it with a feature based algorithm, need to check with Nyall if we have a recipe for this kind of situation.

#4 Updated by Alessandro Pasotti almost 2 years ago

Nevermind, I've found a solution.

#5 Updated by Alessandro Pasotti almost 2 years ago

  • Tracker changed from Feature request to Bug report
  • Status changed from Feedback to In Progress
  • Regression? set to No
  • Crashes QGIS or corrupts data set to No
  • Affected QGIS version set to 3.3(master)

#6 Updated by Alessandro Pasotti almost 2 years ago

  • Pull Request or Patch supplied changed from No to Yes

#7 Updated by Anonymous almost 2 years ago

  • % Done changed from 0 to 100
  • Status changed from In Progress to Closed

Also available in: Atom PDF