Bug report #20061

Repeated switching on and off the editing mode of the ORACLE-layer freezes qgis

Added by Evgeniy Z almost 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Normal
Assignee:Jürgen Fischer
Category:Data Provider/Oracle
Affected QGIS version:3.2.3 Regression?:No
Operating System:Windows 10 x64 Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:Yes Copied to github as #:27883

Description

QGIS 3.2.3
In project only one Oracle-layer, for example.
If I try to commit after each change of geometry, then the QGis starts to commit very slowly with some kind of progression and take a lot of RAM.
Example:
9 commits - 1GB RAM - ~10sec;
10 commits - 3,5 RAM - ~40sec;
11 commits - >12GB RAM - >4min (kill process).

Also, a similar situation is observed if you do not commit, but only turn on and off the editing mode. But more repetitions.

History

#1 Updated by Nyall Dawson almost 2 years ago

  • Status changed from Open to Feedback

Have you tried with no plugins enabled?

#2 Updated by Evgeniy Z almost 2 years ago

Nyall Dawson wrote:

Have you tried with no plugins enabled?

oh... I apologize for the trouble. Now I tried with no plugins and it worked normally. Thank you.

#3 Updated by Giovanni Manghi almost 2 years ago

  • Resolution set to invalid
  • Status changed from Feedback to Closed

Also available in: Atom PDF