Bug report #2005

interpolation plugin crashes QGIS

Added by Paolo Cavallini almost 10 years ago. Updated almost 10 years ago.

Status:Closed
Priority:Low
Assignee:Marco Hugentobler
Category:C++ Plugins
Affected QGIS version: Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:12065

Description

TIN interpolation using lines (not points) from the attached shp crashes QGIS:

Fatal: ASSERT failure in QVector<T>::operator[]: "index out of range", file /usr/include/qt4/QtCore/qvector.h, line 337

QGIS r11788 compiled on debian unstable

fiumi-princ.dbf.tar.gz (184 KB) Paolo Cavallini, 2009-10-12 10:46 AM

History

#1 Updated by Marco Hugentobler almost 10 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Fixed in . However, the result of the interpolation is not good because of a bug that occurs in case of complicated constrained triangulations. I'll open a new bug for that and close this one.

Also available in: Atom PDF