Bug report #20020

Geopackage avoid intersection allow no geometry

Added by Lene Fischer almost 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Normal
Assignee:Alessandro Pasotti
Category:Digitising
Affected QGIS version:3.3(master) Regression?:Yes
Operating System:Windows 7 Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:27842

Description

Digitizing or copy/paste in a geopackage layer with 'avoid intersection' on.
If I paste features in a polygon layer and one or more features with totally overlap (are duplicate) Geopackage allows insert in attribute table without a geometry. Result: 'Could not commit changes to layer'

Associated revisions

Revision 08b6b606
Added by Alessandro Pasotti almost 2 years ago

Show a warning when pasted feature geometry collapsed

... due to due to intersection avoidance

Features are still pasted but the user is warned.

Fixes #20020

History

#1 Updated by Alessandro Pasotti almost 2 years ago

  • Status changed from Open to Feedback

I'm not sure about the expected behavior: when copy-pasting, I would expect that even if geometry is not compatible or it is nullified by the avoid intersection filter, the attributes were copied successfully in the destination layer, in case I wanted to re-digitize or fix the geometries.

What do you think is the expected behavior in such a situation?

#2 Updated by Lene Fischer almost 2 years ago

While inserting a feature with no geometry I would like to get an errormessage just after the insertion, not wait untill I´ll try to save - then I will know which action that was wrong.

#3 Updated by Lene Fischer almost 2 years ago

  • Status changed from Feedback to Open

#4 Updated by Alessandro Pasotti almost 2 years ago

A warning message is actually a good idea, but do you agree with me that the feature(s) should be pasted anyway, even if the geometries are null/empty?

#5 Updated by Alessandro Pasotti almost 2 years ago

  • Assignee set to Alessandro Pasotti

#6 Updated by Giovanni Manghi almost 2 years ago

  • Category changed from Geometry to Digitising

Why this was tagged a regression? is the behavior in 2.18 different?

#7 Updated by Alessandro Pasotti almost 2 years ago

  • Pull Request or Patch supplied changed from No to Yes

#8 Updated by Anonymous almost 2 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

#9 Updated by Lene Fischer almost 2 years ago

Thanks :-)

Also available in: Atom PDF