Bug report #20003

restore the "precision" parameter in the"join attributes by location" tool

Added by Ludovic JACQUET almost 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Processing/QGIS
Affected QGIS version:3.3(master) Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:wontfix
Crashes QGIS or corrupts data:No Copied to github as #:27825

Description

On qgis 2.18 in Join attributes by location we can choice accuracy for spatial criteria, but since QGIS 3.0 I don't see this function.

History

#1 Updated by Giovanni Manghi almost 2 years ago

  • Operating System deleted (Windows 10)
  • Affected QGIS version changed from 3.2.2 to 3.3(master)
  • Subject changed from Loss Accuracy on Join attributes by location to restore the "precision" parameter in the"join attributes by location" tool

#2 Updated by Nyall Dawson almost 2 years ago

  • Resolution set to wontfix
  • Status changed from Open to Closed

This is a "won't fix". The setting in 2.x was extremely misleading in that it did not actually add an accuracy threshold distance, but instead was setting a "maximum distance in which results are totally random"! After group discussion the consensus was that the setting was misleading and very dangerous and accordingly has been dropped.

If you want a real tolerance behaviour the best approach is to buffer one of your input data sets by the tolerance before performing the analysis.

Also available in: Atom PDF