Bug report #19982

"Save scratch layer" does not use same dialog as "save vector layer": very few options available

Added by Harrissou Santanna almost 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Vectors
Affected QGIS version:3.3(master) Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:wontfix
Crashes QGIS or corrupts data:No Copied to github as #:27804

Description

Add a temporary scratch layer
Click the icon next to it in order to save it on disk. The "Save scratch layer" dialog shows less options than if you had used the "Export --> Export features as..." command.
This makes the function not really interesting imho.

savevectorlayer.png (18 KB) Harrissou Santanna, 2018-09-30 04:29 PM

savescratchlayer.png (9.24 KB) Harrissou Santanna, 2018-09-30 04:29 PM

History

#1 Updated by Nyall Dawson almost 3 years ago

  • Resolution set to wontfix
  • Status changed from Open to Closed

This is by design - any option which changes the structure of the nature is hidden, because the layer is swapped in place. thus dropping field alteration, crs changing, etc would result in a malformed layer.

#2 Updated by Harrissou Santanna almost 3 years ago

Oh yeah, you are right, I forgot that aspect of the features. Users Doc might need some precision on this I think.
Should CRS be considered as altering the geometries? Or is it because of some complex internals of the code that it does not allow modification?
Btw, taken the esri shapefile output, i see a "SHPT" option that (I did not try it) makes me feel that it could affect the geometry.

Also available in: Atom PDF