Bug report #19971

QGIS 3.3 MASTER dbmanager time execution query not present

Added by salvatore fiandaca almost 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Normal
Assignee:matteo ghetta
Category:Translations and international
Affected QGIS version:3.3(master) Regression?:Yes
Operating System:win 10 - osgeo4w Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:27793

Description

in QGIS 2.18 the query execution time is present in the dbmanager,
in the master it is no longer present.

Immagine 1.png - screeshot (108 KB) salvatore fiandaca, 2018-09-27 04:32 PM

History

#1 Updated by Alessandro Pasotti almost 2 years ago

  • Assignee set to Alessandro Pasotti

#2 Updated by Alessandro Pasotti almost 2 years ago

  • Status changed from Open to Feedback

I cannot reproduce on linux, is it windows only?

#3 Updated by salvatore fiandaca almost 2 years ago

Alessandro Pasotti wrote:

I cannot reproduce on linux, is it windows only?

I just checked into GNU / Linux Mint 19
QGIS 3.2.3 there is no
QGIS master - compiled a month ago there is not

#4 Updated by Giovanni Manghi almost 2 years ago

also Ok here: master/kubuntu 18.04

#5 Updated by Alessandro Pasotti almost 2 years ago

  • Status changed from Feedback to Open
  • Assignee changed from Alessandro Pasotti to matteo ghetta
  • Category changed from DB Manager to Translations and international

It's a bug in the italian translations:

>>> self.tr("{0} rows, {1:.3f} seconds")
'{0} righe, {1:.1f} secondi {0}?} {1:.3f?}'

self.tr("{0} rows, {1:.3f} seconds").format(123, 1234.56789)  # Error!

#6 Updated by Alessandro Pasotti almost 2 years ago

btw, even if the translation was ok, there is still an error in the reported value ... I'm fixing it now.

#7 Updated by Alessandro Pasotti almost 2 years ago

See: https://github.com/qgis/QGIS/pull/8101 for some (mostly unrelated) issues

#8 Updated by Jürgen Fischer almost 2 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

Fixed in transifex

Also available in: Atom PDF