Bug report #19951

Edit mode doesn't work when ogr vector layers have filters

Added by Loïc BARTOLETTI about 2 years ago. Updated about 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Editing
Affected QGIS version:3.3(master) Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:27773

Description

When you add a filter to a layer1, the editing mode is disabled

[1] Confirmed on a geopackage but not with postgis

Ref #16027


Related issues

Related to QGIS Application - Bug report #16027: Editing GeoPackage from DWG/DXF Import after Save as Laye... Closed 2017-01-02
Duplicates QGIS Application - Feature request #18428: Editing of a filtered OGR vector layer Open 2018-03-13

History

#1 Updated by Giovanni Manghi about 2 years ago

  • Status changed from Open to Feedback

#2 Updated by Regis Haubourg about 2 years ago

  • Subject changed from Edit mode doesn't works when layers have filters to Edit mode doesn't work when layers have filters

#3 Updated by Regis Haubourg about 2 years ago

  • Subject changed from Edit mode doesn't work when layers have filters to Edit mode doesn't work when ogr vector layers have filters
  • Status changed from Feedback to Closed

This concerns OGR provider, not database providers.
If you add gpkg using vector layer UI or drag/drop, this is read by OGR.
This is a duplicate of #18428-3 feature request then.

#4 Updated by Jürgen Fischer about 2 years ago

  • Description updated (diff)

#5 Updated by Alessandro Pasotti almost 2 years ago

#6 Updated by Jürgen Fischer over 1 year ago

  • Related to Bug report #16027: Editing GeoPackage from DWG/DXF Import after Save as Layer Definition File added

Also available in: Atom PDF