Bug report #19949

New maps panels position is not restored after saving and opening a project

Added by salvatore fiandaca about 3 years ago. Updated about 3 years ago.

Status:Closed
Priority:High
Assignee:-
Category:GUI
Affected QGIS version:3.3(master) Regression?:No
Operating System:win 10 - osgeo4w Easy fix?:No
Pull Request or Patch supplied:No Resolution:up/downstream
Crashes QGIS or corrupts data:No Copied to github as #:27771

Description

creating three new maps and two of these overlap in a single window, at the reopening of the project the three windows are again separated.

a1.png - screenshot 1 (326 KB) salvatore fiandaca, 2018-09-26 08:00 AM

a2.png - screenshot 2 (338 KB) salvatore fiandaca, 2018-09-26 08:00 AM

new_map.7z - data and project (206 KB) salvatore fiandaca, 2018-09-26 08:02 AM

b2.PNG - Reopening (901 KB) luca bellani, 2018-09-26 05:09 PM

b1.PNG - Before (1.37 MB) luca bellani, 2018-09-26 05:09 PM

History

#1 Updated by Giovanni Manghi about 3 years ago

  • Subject changed from New map ctrl + M overlap windows to New maps panels position is not restored after saving and opening a project

#2 Updated by luca bellani about 3 years ago

More examples.

#3 Updated by Nyall Dawson about 3 years ago

  • Resolution set to up/downstream
  • Status changed from Open to Closed

This is a due to a limitation in qt (missing feature in dock position handling) and there's no way we can fix this in qgis.

Also available in: Atom PDF