Bug report #19925

With nested models, outputs from child model do not appear in the dialog when run from the toolbox

Added by Olivier Dalang about 3 years ago. Updated about 3 years ago.

Status:Closed
Priority:Normal
Assignee:Nyall Dawson
Category:Processing/Modeller
Affected QGIS version:3.3(master) Regression?:No
Operating System:Windows 10 Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:27749

Description

Hi !

When working with nested models (an user model in another user model) in processing, outputs from child models don't appear as output from the parent's model when triggered from the toolbox.

Steps to reproduce

- Create a "child model" with a vector input and basic function (e.g. buffer) which you set as output
- Create a "parent model" with a vector input and the "child model", which you set as output
- From the toolbox, run the algorithm, and note that the output layer doensn't appear in the dialog

Notes

- Strangely, everything works as expected when using the "play" button from the modeler itself.
- Algorithms are likely to fail because of missing OUTPUT parameter

Cheers,

Olivier

History

#1 Updated by Nyall Dawson about 3 years ago

  • Assignee set to Nyall Dawson

#2 Updated by Nyall Dawson about 3 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

Fixed in master

Also available in: Atom PDF