Bug report #19908

Results of intersects geotraitement tools are not the same between 2.18 and 3.2.3

Added by Florent LUQUET about 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Vectors
Affected QGIS version:3.2.3 Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:no timely feedback
Crashes QGIS or corrupts data:No Copied to github as #:27732

Description

The tool "Select by location" into "Processing Toolbox" responds a wrong result on the 3.2.3 version. See below the attachements images.
The data are polygons (not multi polygons) with the same CRS.

QGIS 2.18.22 - Good intersects result.png (143 KB) Florent LUQUET, 2018-09-21 09:54 AM

QGIS 3.2.3 - Error intersects result.png (146 KB) Florent LUQUET, 2018-09-21 09:57 AM

indicateur_3.gpkg (1.66 MB) Florent LUQUET, 2018-09-21 12:03 PM

History

#1 Updated by Nyall Dawson about 2 years ago

  • Status changed from Open to Feedback

Please attach the sample data used.

#2 Updated by Florent LUQUET about 2 years ago

Ok. Data into a geopackage attachement. Thanks

#3 Updated by Nyall Dawson about 2 years ago

I've investigated and the cause of this issue is that the geometries in dalle_litto_3d are all invalid -- the polygon rings are not closed. This also causes issues with other QGIS tools, e.g. you can't click to select polygons in this layer or use the identify tool on them. The solution is to run the "repair geometries" algorithm over this layer to fix the geometries.

I'm curious how this layer was built though -- if it was the result of a QGIS algorithm or operation then that needs fixing to output valid polygons.

#4 Updated by Nyall Dawson almost 2 years ago

  • Resolution set to no timely feedback
  • Status changed from Feedback to Closed

Also available in: Atom PDF