Bug report #1989

v.distance should have radio buttons, not checkboxes

Added by Paolo Cavallini about 11 years ago. Updated over 4 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:GRASS
Affected QGIS version:master Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:12049

Description

In the current v.distance GRASS module, users can select multiple metrics, but only a target column to write to; as a result, if >1 metric is selected, they get an error. The checkboxes should be replaced by radio buttons, so that only one metric can be selected at a time.

History

#1 Updated by Giovanni Manghi almost 11 years ago

The checkboxes make sense in the GRASS gui because in GRASS you can specify more than one column name as the field is open.

In QGIS the field to specify the column name is a dropdown, but radio buttons seems to be not available in qgis GRASS plugin.

Workaround:

1) replace the dropdown with a open field

2) make possibile to select more than one column name in the dropdown

3) introduce radio buttons in the plugin

#2 Updated by Giovanni Manghi almost 9 years ago

  • Target version changed from Version 1.7.0 to Version 1.7.4

#3 Updated by Paolo Cavallini almost 9 years ago

  • Crashes QGIS or corrupts data set to No
  • Affected QGIS version set to master
  • Pull Request or Patch supplied set to No
  • Assignee deleted (Lorenzo Masini)

#4 Updated by Paolo Cavallini over 8 years ago

  • Target version changed from Version 1.7.4 to Version 1.8.0

#5 Updated by Paolo Cavallini about 8 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#6 Updated by Jürgen Fischer over 6 years ago

  • Target version changed from Version 2.0.0 to Future Release - Lower Priority

#7 Updated by Radim Blazek over 4 years ago

  • Status changed from Open to Closed
  • Resolution set to fixed/implemented

Output columns can be multiple from QGIS 2.14.

Also available in: Atom PDF