Bug report #19829

Loading georeferenced PDF crashes QGIS

Added by Patrick Harvey over 1 year ago. Updated over 1 year ago.

Status:Closed
Priority:High
Assignee:-
Category:Data Provider
Affected QGIS version:3.2.2 Regression?:No
Operating System:Win10 Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:Yes Copied to github as #:27653

Description

Hi See below for crash details.

I was trying to open a georeferenced PDF at the time

User Feedback

Report Details

Crash ID: 7c905979abe6fdeec441d028205179170892e781

Stack Trace

GDALWarpOperation::WarpRegionToBuffer :
GDALWarpOperation::WarpRegionToBuffer :
VRTWarpedDataset::ProcessBlock :
VRTWarpedRasterBand::IReadBlock :
GDALRasterBand::GetLockedBlockRef :
GDALRasterBand::IRasterIO :
GDALRasterBand::RasterIO :
GDALWarpOperation::operator= :
GDALWarpOperation::operator= :
QgsMultiBandColorRenderer::block :
QgsBrightnessContrastFilter::block :
QgsHueSaturationFilter::block :
QgsRasterResampleFilter::block :
QgsRasterProjector::block :
QgsRasterIterator::readNextRasterPart :
QgsRasterDrawer::draw :
QgsRasterLayerRenderer::render :
QgsMapRendererParallelJob::renderLayerStatic :
QgsMapRendererParallelJob::renderingFinished :
QgsImageOperation::overlayColor :
QgsArchive::zip :
QtConcurrent::ThreadEngineBase::run :
QThreadPoolPrivate::reset :
QThread::start :
BaseThreadInitThunk :
RtlUserThreadStart :

QGIS Info
QGIS Version: 3.2.2-Bonn
QGIS code revision: 26842169e9
Compiled against Qt: 5.9.2
Running against Qt: 5.9.2
Compiled against GDAL: 2.2.4
Running against GDAL: 2.2.4

System Info
CPU Type: x86_64
Kernel Type: winnt
Kernel Version: 10.0.17134

History

#1 Updated by Giovanni Manghi over 1 year ago

  • Crashes QGIS or corrupts data changed from No to Yes
  • Subject changed from Loading georeferenced PDF to Loading georeferenced PDF crashes QGIS
  • Category changed from Unknown to Data Provider
  • Status changed from Open to Feedback
  • Priority changed from Normal to High

Can you attach/link it?

#2 Updated by Patrick Harvey over 1 year ago

https://maps.six.nsw.gov.au/etopo.html

I was trying the canberra topi but none of them load

#3 Updated by Giovanni Manghi over 1 year ago

Patrick Harvey wrote:

https://maps.six.nsw.gov.au/etopo.html

I was trying the canberra topi but none of them load

no crash here on master/linux but also no map (or just super slow to load). What about 2.18?

#4 Updated by Even Rouault over 1 year ago

Cannot reproduce on Linux with QGIS master (3.3) with "9135-1N ABERBALDIE.pdf". The display is slow due to on-the-fly VRT reprojection

#5 Updated by Giovanni Manghi over 1 year ago

Please try on QGIS 3.4.1, if the issue is still valid change the affected version, thanks.

#6 Updated by Patrick Harvey over 1 year ago

Loading the PDF worked this time, however, took about 10 minutes to load. This is still far better than not loading at all as previously reported.

#7 Updated by Giovanni Manghi over 1 year ago

  • Resolution set to fixed/implemented
  • Status changed from Feedback to Closed

Patrick Harvey wrote:

Loading the PDF worked this time, however, took about 10 minutes to load. This is still far better than not loading at all as previously reported.

please file a separate ticket for the slowness problem.

Also available in: Atom PDF