Bug report #19823

crash after topology check

Added by Torsten Hase almost 2 years ago. Updated over 1 year ago.

Status:Closed
Priority:High
Assignee:-
Category:Processing/QGIS
Affected QGIS version:3.2.2 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:no timely feedback
Crashes QGIS or corrupts data:Yes Copied to github as #:27647

Description

User Feedback

I mad some topology check and editing of postgis tables. QGIS crashed after closing.

Report Details

Crash ID: 7d5efd3afc1bfd58a33dd40b4219908af7eab42b

Stack Trace

QgsOrganizeTableColumnsDialog::QgsOrganizeTableColumnsDialog :
QgsRubberBand::QgsRubberBand :
QgsRubberBand::asGeometry :
QgsRubberBand::reset :
version :
QMetaObject::activate :
QDockWidget::visibilityChanged :
QDockWidget::event :
QApplicationPrivate::notify_helper :
QApplication::notify :
QgsApplication::notify :
QCoreApplication::notifyInternal2 :
QWidgetPrivate::hideChildren :
QWidgetPrivate::hide_helper :
QWidget::setVisible :
QWidgetPrivate::close_helper :
QWidget::~QWidget :
std::basic_string<char,std::char_traits<char>,std::allocator<char> >::append :
main :
BaseThreadInitThunk :
RtlUserThreadStart :

QGIS Info
QGIS Version: 3.2.2-Bonn
QGIS code revision: 26842169e9
Compiled against Qt: 5.9.2
Running against Qt: 5.9.2
Compiled against GDAL: 2.2.4
Running against GDAL: 2.2.4

System Info
CPU Type: x86_64
Kernel Type: winnt
Kernel Version: 10.0.17134

History

#1 Updated by Giovanni Manghi almost 2 years ago

  • Status changed from Open to Feedback
  • Crashes QGIS or corrupts data changed from No to Yes

Can you replicate 100% of times while doing the same operations? Please add step by step instructions on how replicate, possibly attaching the necessary data.

#2 Updated by Giovanni Manghi almost 2 years ago

Also try with no 3rd party plugins or even better on new/clean profile.

#3 Updated by Jürgen Fischer almost 2 years ago

  • Subject changed from gis crashed to crash after topology check
  • Description updated (diff)

#4 Updated by Giovanni Manghi almost 2 years ago

Please try on QGIS 3.4.1, if the issue is still valid change the affected version, thanks.

#5 Updated by Alexander Bruy over 1 year ago

  • Resolution set to no timely feedback
  • Status changed from Feedback to Closed

Closed for the lack of feedback. Please reopen if necessary.

Also available in: Atom PDF