Bug report #19684

The Extract layer extent algorithm should not take table in input

Added by Harrissou Santanna over 1 year ago. Updated about 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Processing/Core
Affected QGIS version:3.3(master) Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:27509

Description

Geometryless layer should not be allowed as input data to extract extent

History

#1 Updated by Victor Olaya about 1 year ago

  • Status changed from Open to Feedback

Maybe that algorithm can be removed? It is redundant, since all that it does can be done with the "layer from extent" one

#2 Updated by Nyall Dawson about 1 year ago

Maybe that algorithm can be removed? It is redundant, since all that it does can be done with the "layer from extent" one

They address different use cases though -- for models, wouldn't we need both options?

#3 Updated by Harrissou Santanna about 1 year ago

  • Status changed from Feedback to Open

#4 Updated by Nyall Dawson about 1 year ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

This was fixed in 3.6

Also available in: Atom PDF