Bug report #19680

Styles saved in a Spatialite DB are then not available to be used

Added by Giovanni Manghi almost 2 years ago. Updated over 1 year ago.

Status:Closed
Priority:High
Assignee:Alessandro Pasotti
Category:Symbology
Affected QGIS version:3.3(master) Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:27505

Description

Tested on master/linux.

import a layer (say both of the same type of geometry) into a SL db

add to the canvas one of them, create a symbology, save it to the SL DB as default

try add again the same layer to the project, the default style is not loaded

try load the style manually from style > load style > database styles manager, the style just saved does not show

Associated revisions

Revision b1c7734a
Added by Alessandro Pasotti over 1 year ago

[bugfix] spatialite load default style

Fixes #19680 - Styles saved in a Spatialite DB are then not available to be used

History

#1 Updated by Alessandro Pasotti over 1 year ago

  • Assignee set to Alessandro Pasotti

#2 Updated by Alessandro Pasotti over 1 year ago

There are actually two bug or three bugs here, one unreported is fixed with:
https://github.com/qgis/QGIS/pull/7925

The last one "the style just saved does not show" is also fixed (PR on the way).

For the second one I'm working on it but looks like it was disabled about one year ago with ba62ffce2c7fa6f6331e33f751e4a901a26e8e45 , that may not be the only reason though.

#3 Updated by Alessandro Pasotti over 1 year ago

  • Status changed from Open to In Progress

#4 Updated by Alessandro Pasotti over 1 year ago

  • Pull Request or Patch supplied changed from No to Yes

#5 Updated by Anonymous over 1 year ago

  • % Done changed from 0 to 100
  • Status changed from In Progress to Closed

Also available in: Atom PDF