Bug report #19677

Qgis crashes on opening new grass mapset using the grass plugin

Added by samuel ngugi almost 2 years ago. Updated over 1 year ago.

Status:Closed
Priority:High
Assignee:-
Category:GRASS
Affected QGIS version:3.2 Regression?:Yes
Operating System:windows 10 pro Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:Yes Copied to github as #:27502

Description

Hello, I have been trying to create a new mapset in Qgis 3.2.0 Bonn using the grass plugin, and selecting 'create new mapset.' When trying to create a new GRASS 'location', Qgis crashes. I would like to know a solution since I have tried this repeatedly with the same result.

Here is the backtrace:----------------------------------------------

User Feedback

Report Details

Crash ID: 6249da9efcf2c37fd2d0c2088398c589de12a117

Stack Trace

RtlRaiseStatus :
memset :
setjmpex :
G_fatal_error :
G_getenv :
read_datum_table :
GPJ_osr_to_grass :
GPJ_wkt_to_grass :
version :
version :
QMetaObject::activate :
QWizard::subTitleFormat :
QWizard::next :
QMetaObject::activate :
QAbstractButton::clicked :
QAbstractButton::click :
QAbstractButton::mouseReleaseEvent :
QWidget::event :
QApplicationPrivate::notify_helper :
QApplication::notify :
QgsApplication::notify :
QCoreApplication::notifyInternal2 :
QApplicationPrivate::sendMouseEvent :
QSizePolicy::QSizePolicy :
QSizePolicy::QSizePolicy :
QApplicationPrivate::notify_helper :
QApplication::notify :
QgsApplication::notify :
QCoreApplication::notifyInternal2 :
QGuiApplicationPrivate::processMouseEvent :
QWindowSystemInterface::sendWindowSystemEvents :
QEventDispatcherWin32::processEvents :
DispatchMessageW :
DispatchMessageW :
QEventDispatcherWin32::processEvents :
qt_plugin_query_metadata :
QEventLoop::exec :
QCoreApplication::exec :
main :
BaseThreadInitThunk :
RtlUserThreadStart :

QGIS Info
QGIS Version: 3.2.0-Bonn
QGIS code revision: bc43194061
Compiled against Qt: 5.9.2
Running against Qt: 5.9.2
Compiled against GDAL: 2.2.4
Running against GDAL: 2.2.4

System Info
CPU Type: x86_64
Kernel Type: winnt
Kernel Version: 10.0.10240


Related issues

Duplicates QGIS Application - Bug report #19131: QGIS crashed while I was creating a new grass location Closed 2018-06-07
Duplicated by QGIS Application - Bug report #20327: Grass crashes when try to create mapset Open 2018-11-02

History

#1 Updated by Alexander Bruy almost 2 years ago

  • Assignee deleted (Alexander Bruy)

#2 Updated by Giovanni Manghi almost 2 years ago

  • Status changed from Open to Feedback

Works fine on master/linux.

#3 Updated by Giovanni Manghi over 1 year ago

Please try on QGIS 3.4.1, if the issue is still valid change the affected version, thanks.

#4 Updated by Jürgen Fischer over 1 year ago

  • Duplicates Bug report #19131: QGIS crashed while I was creating a new grass location added

#5 Updated by Jürgen Fischer over 1 year ago

  • Status changed from Feedback to Closed
  • Resolution set to duplicate

#6 Updated by Jürgen Fischer over 1 year ago

Also available in: Atom PDF