Bug report #19581

Docked panel height changed on next startup

Added by Jean-François Bourdon about 2 years ago. Updated about 2 years ago.

Status:Rejected
Priority:Normal
Assignee:-
Category:GUI
Affected QGIS version:3.0.0 Regression?:No
Operating System:Windows 7 64x Easy fix?:No
Pull Request or Patch supplied:No Resolution:up/downstream
Crashes QGIS or corrupts data:No Copied to github as #:27408

Description

When two or more panels are docked on the same side of the GUI (I only tested the left side to be fair), the height of each individual panel is not always saved as when QGIS is reopened, the height distribution is changed.

I initially tought that it was a problem with the plugin I used (Value Tool), but the problem is also present with a second plugin (Search QMS) and it also present when I only use native panels.

When I have only two native panels docked (eg. Layers and Browser), the height seems to be preserved, but if I add a third one (eg. Processing Toolbox), it is not anymore. If I have one native panel docked along with one from a plugin (eg. Value Tool or Search QMS), the height I never preserved.

Before_restart.png - Height distribution before closing QGIS (32.7 KB) Jean-François Bourdon, 2018-08-09 07:31 PM

After_restart.png - Height distribution after reopening QGIS (33.5 KB) Jean-François Bourdon, 2018-08-09 07:31 PM

History

#2 Updated by Nyall Dawson about 2 years ago

  • Resolution set to up/downstream
  • Status changed from Open to Rejected

This is an upstream Qt library issue - we can't fix it in QGIS.

Also available in: Atom PDF