Bug report #19570

Raster terrain analysis Relief Crashes QGIS

Added by Michael Knopp almost 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Processing/Core
Affected QGIS version:3.2.1 Regression?:No
Operating System:Windows 7 Enterprise Service Pack 1 Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:Yes Copied to github as #:27397

Description

When I try and run the Relief process in the Raster terrain analysis group on a .bil raster DEM of SRTM data it crashes QGIS when ran as "Run in Background".

I have tried this on three different DEM files in a project with other layers and in a new project where the DEM is the only layer. It crashes every time.

I have tried checking the "Generate relief classes automatically" and defining my own colors by hand.

I have ran the GDAL Color relief process and it works just fine. I have also ran the Aspect, Hillshade, and Slope under Raster terrain analysis group and they all function just fine.

I loaded the DEM into QGIS 2.18.22 and ran the Raster Terrain Analysis Relief there and it worked just fine. Also, when it is ran as a batch process in 3.2.1 it works just fine.

Screencap 001.png - New project with single layer (214 KB) Michael Knopp, 2018-08-09 05:34 AM

Screencap 002.png - Setting for Relief (66.2 KB) Michael Knopp, 2018-08-09 05:35 AM

n06_e126_1arc_v3_bil.zip - zip containing .bil file (1.71 MB) Michael Knopp, 2018-08-09 05:35 AM

Screencap 003.png - Greyed out QGIS right before crash (168 KB) Michael Knopp, 2018-08-09 05:35 AM

Associated revisions

Revision c860696a
Added by Nyall Dawson almost 2 years ago

Fix crash in relief calculation when exporting distribution to csv

Fixes #19570

Revision d39bdcda
Added by Nyall Dawson almost 2 years ago

[processing] Don't create frequency distribution file for relief
algorithm by default

Refs #19570

Revision 1fe1a99e
Added by Nyall Dawson almost 2 years ago

Fix crash in relief calculation when exporting distribution to csv

Fixes #19570

(cherry-picked from c860696)

Revision e39cb4c3
Added by Nyall Dawson almost 2 years ago

[processing] Don't create frequency distribution file for relief
algorithm by default

Refs #19570

(cherry-picked from d39bdcd)

History

#1 Updated by Nyall Dawson almost 2 years ago

  • Status changed from Open to Feedback

Can you share your files? I can't reproduce here.

#2 Updated by Michael Knopp almost 2 years ago

Sure.

I am attaching the zip file with the .bil SRTM data inside of it. I am also attaching three screen caps showing the setup that I tested and the resulting greyed out program just before it crashes.

Let me know if there is anything else that I can do to help.

#3 Updated by Nyall Dawson almost 2 years ago

  • Status changed from Feedback to Open

Thanks -- I can reproduce with that dataset

#4 Updated by Nyall Dawson almost 2 years ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

#5 Updated by Giovanni Manghi almost 2 years ago

  • Resolution set to fixed/implemented

#6 Updated by Nyall Dawson almost 2 years ago

If you're looking for a quick workaround which works in 3.2.1 - set the "frequency distribution file" to "skip output" in the algorithm dialog.

#7 Updated by Michael Knopp almost 2 years ago

Nyall,

Thank you, but I already processed them through the Batch processing.

Also available in: Atom PDF