Bug report #19536

Boolean classify style not working

Added by Christopher Wesson about 2 years ago. Updated about 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:3.0.2 Regression?:No
Operating System:Windows 10 64-bit Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:27363

Description

Currently using QGIS 3.0.2 Girona

I have polygons with a Boolean field. If I try to colour them based on this field it colours them all with the 'all other' blank value.
If I remove this then the polygons do not show.

I suspect this is because the classification is searching for 'True' or 'False' whereas the Boolean field in the table is always '1' or '0'.

Would be nice to get this fixed by LTR if its not already.

Chris

History

#1 Updated by Giovanni Manghi about 2 years ago

  • Easy fix? changed from Yes to No
  • Status changed from Open to Feedback

Just tested with a PostGIS table on 3.2, works as expected.

#2 Updated by Nyall Dawson about 2 years ago

What layer type are you using? Can you share?

#3 Updated by Giovanni Manghi about 2 years ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

Closing for lack of feedback.

Also available in: Atom PDF