Bug report #19515

QGIS Rapidly Uses RAM on Fedora 28 When Adding Layer

Added by Dylan Richardson almost 2 years ago. Updated almost 2 years ago.

Status:Rejected
Priority:Normal
Assignee:-
Category:Unknown
Affected QGIS version:3.2.1 Regression?:No
Operating System:Fedora 28 Easy fix?:No
Pull Request or Patch supplied:No Resolution:up/downstream
Crashes QGIS or corrupts data:Yes Copied to github as #:27343

Description

Hi all,

I recently did a fresh reinstall of Fedora 28 on my desktop and am experiencing a very peculiar bug where when I add data to QGIS, it rapidly consumes RAM to the point of pushing me to use the swap partition. I've been working with some geojson files of moderate size (~800mb), and it's simply impossible to open them in QGIS. I have attached a .gif of me dropping one geojson file into QGIS and the RAM on my machine going crazy. I will provide whatever debug logs are helpful to get this issue resolved, but I'm not sure what would be useful offhand. I am using kernel 4.17.9, and the only plugins I have installed in QGIS 3.2.1 are quick map services and the vector tile viewer plugin.

Peek 2018-07-30 21-48.gif (1.04 MB) Dylan Richardson, 2018-07-31 04:50 AM

History

#1 Updated by Nyall Dawson almost 2 years ago

  • Resolution set to up/downstream
  • Status changed from Open to Rejected

This is caused by the gdal library consuming geojson files (other formats aren't affected). It's fixed in more recent gdal versions, so you basically need to wait for your distro to package and deploy a more recent gdal.

#2 Updated by Dylan Richardson almost 2 years ago

I'm not sure I understand - Fedora 28 has 2.2.4 in the official repo, is that not new enough? I didn't see anything about this bug in the gdal bug tracker before I asked here, was this fixed in 2.3.1?

Also available in: Atom PDF