Bug report #19500

Layout export - raster divided into tiles, edges evident in pdf/svg

Added by Patrick Connellan over 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:High
Assignee:Nyall Dawson
Category:Map Composer/Printing
Affected QGIS version:3.2.1 Regression?:Yes
Operating System:Windows 10 Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:27328

Description

When exporting layout to SVG/PDF rasters are split into pieces of which the edges are evident in resulting output (see attached). This does not happen when exporting as raster (vector symbology and text also rasterised) (with pdf export). I remember this happening quite a few years ago and was then fixed. The last QGIS version I have where this doesn't happen is QGIS 2.18.13 Compiled against Qt4.8.5, GDAL/OGR 2.2.1 , GEOS 3.5.0-CAPI-1.9.0, QGIS code revision Bcba0bb9eb, on my old computer running Windows 7 if that helps. Also effects QGIS 3.2.0 and 2.18.22 on Windows 10 at least.

rasterTileEdges.jpg (355 KB) Patrick Connellan, 2018-07-27 06:38 AM

Associated revisions

Revision 60b8d052
Added by Nyall Dawson almost 2 years ago

[needs-docs][layouts] Add checkbox to disable raster tiling for PDF/SVG exports

This setting, which is disabled by default and placed into an
"advanced" group on PDF/SFG export, disables the built-in
raster layer tiled rendering. While the tiling is good for
memory usage, it can cause visible "seams" in the rasters
for generated PDF/SVG files.

The setting has a tooltip warning users that disabling the
tiling results in high memory usage during exports.

Fixes #19500

History

#1 Updated by Nyall Dawson over 2 years ago

  • Status changed from Open to Feedback

So to confirm 2.18.14 has this bug, 2.18.13 doesn't?

#2 Updated by Patrick Connellan over 2 years ago

No not sure how long after 2.18.13 it was, I’ll run through them from that point and report back which one one it starts on.

#3 Updated by Nyall Dawson over 2 years ago

Thanks, that'll help a lot!

#4 Updated by Patrick Connellan over 2 years ago

Confirming 2.18.21 has bug and 2.18.20 does not. Cheers

#5 Updated by Giovanni Manghi over 2 years ago

  • Priority changed from Normal to High
  • Status changed from Feedback to Open

#6 Updated by Mathieu Pellerin - nIRV almost 2 years ago

For the record, large raster layers exported through layout (or composer prior to 3.X) were always divided into tiles (the max. number of pixel is 4000-something I think). I'm wondering whether the issue has to do with the PDF reader of the author of this issue, which might have been updated and doesn't render as nicely as it used to.

#7 Updated by Nyall Dawson almost 2 years ago

Actually it's caused by 31a9571855068fce6191c3c3b6d9231f7ef97c7c - for a short period of time we didn't render the rasters in blocks (unintentionally), and that commit fixed the render in blocks approach

#8 Updated by Nyall Dawson almost 2 years ago

  • Status changed from Open to In Progress
  • Assignee set to Nyall Dawson

#9 Updated by Nyall Dawson almost 2 years ago

  • % Done changed from 0 to 100
  • Status changed from In Progress to Closed

Also available in: Atom PDF