Bug report #19471

Crash when start print layout

Added by Patrick Duchesne over 1 year ago. Updated about 1 year ago.

Status:Closed
Priority:High
Assignee:-
Category:Map Composer/Printing
Affected QGIS version:3.2.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:no timely feedback
Crashes QGIS or corrupts data:Yes Copied to github as #:27299

Description

Hi

Each time we try to print our composer, QGIS crash!

Wee use it for work. Help quikly as possible would be appreciate!

Huge thank for your support.

Have a nice day!

Patrick

bug QGIS.png - Oh Uh! image (166 KB) Patrick Duchesne, 2018-07-23 02:25 PM

History

#1 Updated by Harrissou Santanna over 1 year ago

Hi Patrick,
Thanks for reporting.

Wee use it for work. Help quikly as possible would be appreciate!

Nyall Dawson wrote years ago an interesting article about how to get things done quickly in QGIS. It's at http://nyalldawson.net/2016/08/how-to-effectively-get-things-changed-in-qgis/ if you want to give it a look. This can be of interest to you or your employer (if any), if you want this fix done quickly.

Other than that, and while I have no skills to appreciate whether the screenshot you provide is enough, I'd advise you to describe the particular steps before the application crashes and, better, provide a project with data to help developers (try to) reproduce the crash.
Also, does it occur on any project you create or a particular one? Particular paper format? Is it a 2.x old project or a new by 3.2? ...
In summary, the more accurate your issue report is, better are the chances to get it solved in a reasonable delay (regardless Nyall article).

Regards,
H.

#2 Updated by Nyall Dawson over 1 year ago

Can you share the project? Does it crash when you export to PDF? What about PNG?

#3 Updated by Nyall Dawson over 1 year ago

  • Status changed from Open to In Progress

#4 Updated by Nyall Dawson over 1 year ago

  • Status changed from In Progress to Feedback

#5 Updated by Giovanni Manghi over 1 year ago

Please try on QGIS 3.4.1, if the issue is still valid change the affected version, thanks.

#6 Updated by Nyall Dawson about 1 year ago

  • Resolution set to no timely feedback
  • Status changed from Feedback to Closed

Also available in: Atom PDF