Bug report #19444

QGIS 3.2.0 crash while intersecting vector layers

Added by Ricardo Gonzalez almost 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Vectors
Affected QGIS version:3.2 Regression?:No
Operating System:W-10 Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:27272

Description

User Feedback

Crashed while intersecting (trying to) two vector layers with selected items on each of them. (Actually, both layers are equal, one copy of the other).

Report Details

Crash ID: a97cde95ca25d98a2ca9bc870c81e10227711ad8

Stack Trace

QgsNativeAlgorithms::tr :
Vector3D::standardise :
QgsProcessingAlgorithm::runPrepared :
QgsProcessingAlgRunnerTask::run :
PyInit__core :
QgsTask::start :
QThreadPoolPrivate::reset :
QThread::start :
BaseThreadInitThunk :
RtlUserThreadStart :

QGIS Info
QGIS Version: 3.2.0-Bonn
QGIS code revision: bc43194061
Compiled against Qt: 5.9.2
Running against Qt: 5.9.2
Compiled against GDAL: 2.2.4
Running against GDAL: 2.2.4

System Info
CPU Type: x86_64
Kernel Type: winnt
Kernel Version: 10.0.17134

History

#1 Updated by Nyall Dawson almost 2 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

This is fixed in 3.2.1 (Duplicate of #19324)

Also available in: Atom PDF