Bug report #19360

QGIS 3.2.0 crashes when exporting image including GoogleEartg

Added by Patrick Giraudoux almost 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Tools
Affected QGIS version:3.2 Regression?:No
Operating System:Windows 7 Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:27188

Description

There are anomalies when using the Openlayer plugin, Google map > Google satellite. Exporting any kind of image (File > Export > Export Map to Image leads to a complete crash.
Here below the crash report:

Crash ID: 059fc511cf0597c0396959d1053938bd93019461

Stack Trace

WTFCrash :
JSC::evaluate :
JSPropertyNameArrayGetCount :
JSPropertyNameArrayGetCount :
WKConnectionGetTypeID :
QWebFrameAdapter::evaluateJavaScript :
QWebFrame::evaluateJavaScript :
PyCFunction_FastCallDict :
PyObject_GenericGetAttr :
PyEval_EvalFrameDefault :
PyObject_GenericGetAttr :
PyEval_EvalFrameDefault :
PyFunction_FastCallDict :
PyObject_CallFunctionObjArgs :
PyObject_Call :
PyInit_QtCore :
PyInit_QtCore :
PyInit_QtCore :
PyInit_QtCore :
PyInit_QtCore :
QMetaMethod::invoke :
QMetaObject::invokeMethod :
PyCFunction_FastCallDict :
PyObject_GenericGetAttr :
PyEval_EvalFrameDefault :
PyFunction_FastCallDict :
PyObject_CallFunctionObjArgs :
PyObject_Call :
PyInit_sip :
std::basic_string,std::allocator >::shrink_to_fit :
QgsPresetSchemeColorRamp::clone :
QgsMapRendererCustomPainterJob::doRender :
QgsMapRendererCustomPainterJob::start :
QgsMapRendererCustomPainterJob::renderSynchronously :
QgsMapRendererTask::run :
QgsTask::start :
QThreadPoolPrivate::reset :
QThread::start :
BaseThreadInitThunk :
RtlUserThreadStart :

QGIS Info
QGIS Version: 3.2.0-Bonn
QGIS code revision: bc43194061
Compiled against Qt: 5.9.2
Running against Qt: 5.9.2
Compiled against GDAL: 2.2.4
Running against GDAL: 2.2.4

System Info
CPU Type: x86_64
Kernel Type: winnt
Kernel Version: 6.1.7601

History

#1 Updated by Nyall Dawson almost 2 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

This is a bug in the OpenLayers plugin - it needs to be filed in the plugins bug tracker.

Also available in: Atom PDF